Evo 8 Not a lot of power - Mitsubishi Lancer Register Forum
 
 

Go Back   Mitsubishi Lancer Register Forum > Technical > Engine / Turbo

Reply
 
Thread Tools Rate Thread Display Modes
Old 10-06-2019, 09:11   #1
broraboy
Senior User
 
broraboy's Avatar
 
Join Date: Oct 2007
Location: Elgin, Scotland
Car: Evo 6 Gravel Rally Car
Posts: 742
Evo 8 Not a lot of power

Im looking for any advice I can get. Have an Evo 8 rally car with an 80 series turbo on it. Turbo is new. Boost leak test done no leaks. Compression test done 150 across the board. Leakdown test done, all good. Car is boosting to 1.4 bar. Expecting 1.8. Unable to get any more out of it. Any ideas as to what could be restricting the power?
__________________
Evo 6 Rally car and Evo 6.9 Rally car
broraboy is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 10-06-2019, 13:26   #2
strange_days_uk
Simon - EVO V
 
strange_days_uk's Avatar
 
Join Date: Feb 2016
Car: EVO V
My Car
Posts: 1,722
could it be a faulty wastegate?
__________________
http://www.ap-tuning.co.uk/

Quote:
Originally Posted by Aidy View Post
Most TME owners have never driven an evo, including their own.
strange_days_uk is offline   Reply With Quote
Old 10-06-2019, 13:52   #3
grants
Senior User
 
grants's Avatar
 
Join Date: Sep 2003
My Car
Posts: 8,948
A "sock" or similar left in the air intake plumbing after the last event clean up

It's been done many times

Grant
grants is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 10-06-2019, 14:34   #4
stu8
Senior User
 
stu8's Avatar
 
Join Date: Aug 2003
Location: Southport
Car: Evo V - geekmapped.com
My Car
Posts: 21,663
go to actuator on turbo and make sure it is pre-tensioned correctly and holding the wastegate tight shut. What actuator do you have fitted? The remove the pipe off the actuator and blank it. The accelerate carefully watching boost, see if you get more, should help narrow it down

Stu
__________________
CPP Motor Developments - CPP MLR page - CPP Facebook
RG Motorsport - www.rgmotorsport.co.uk

Evo 4-6 left over parts for sale
stu8 is offline   Reply With Quote
The Following User Says Thank You to stu8 For This Useful Post:
broraboy (12-06-2019)
Old 10-06-2019, 19:58   #5
foxbat
Registered User
 
Join Date: Dec 2009
Car: JDM Evo VI GSR
Posts: 285
Many possibilities, in my case it was a cracked turbine housing.
foxbat is offline   Reply With Quote
Old 12-06-2019, 19:54   #6
broraboy
Senior User
 
broraboy's Avatar
 
Join Date: Oct 2007
Location: Elgin, Scotland
Car: Evo 6 Gravel Rally Car
Posts: 742
Its a new Evo 9 turbo. Took the wastegate as being ok as this is second turbo with similar results. Was 1.2 bar on second hand turbo, 1.3-1.4 on new 80 series. 3 port solenoid checked and not leaking. Checked for boost leaks and ok. Grants, taken off intake pipework and no socks lol
__________________
Evo 6 Rally car and Evo 6.9 Rally car
broraboy is offline   Reply With Quote
Old 12-06-2019, 20:10   #7
stu8
Senior User
 
stu8's Avatar
 
Join Date: Aug 2003
Location: Southport
Car: Evo V - geekmapped.com
My Car
Posts: 21,663
Quote:
Originally Posted by broraboy View Post
Its a new Evo 9 turbo. Took the wastegate as being ok as this is second turbo with similar results. Was 1.2 bar on second hand turbo, 1.3-1.4 on new 80 series. 3 port solenoid checked and not leaking. Checked for boost leaks and ok. Grants, taken off intake pipework and no socks lol
Did you do the checks I mentioned above? If its not pretensioned correctly it will underboost and overspeed

As its a rally car, does it have a restrictor in the turbo setup, is the actuator and other turbo stuff as you would find on a standard evo 9?

Stu
__________________
CPP Motor Developments - CPP MLR page - CPP Facebook
RG Motorsport - www.rgmotorsport.co.uk

Evo 4-6 left over parts for sale
stu8 is offline   Reply With Quote
Old 12-06-2019, 20:39   #8
broraboy
Senior User
 
broraboy's Avatar
 
Join Date: Oct 2007
Location: Elgin, Scotland
Car: Evo 6 Gravel Rally Car
Posts: 742
Quote:
Originally Posted by stu8 View Post
Did you do the checks I mentioned above? If its not pretensioned correctly it will underboost and overspeed

As its a rally car, does it have a restrictor in the turbo setup, is the actuator and other turbo stuff as you would find on a standard evo 9?

Stu
Stu, yes there is tension, I might increase it so as to eliminate it completely. Yes im running 34mm restrictor
__________________
Evo 6 Rally car and Evo 6.9 Rally car
broraboy is offline   Reply With Quote
Old 12-06-2019, 20:43   #9
stu8
Senior User
 
stu8's Avatar
 
Join Date: Aug 2003
Location: Southport
Car: Evo V - geekmapped.com
My Car
Posts: 21,663
Quote:
Originally Posted by broraboy View Post
Stu, yes there is tension, I might increase it so as to eliminate it completely. Yes im running 34mm restrictor
not really sure on the effect of the restrictor, guess it limits flow at higher revs, but dont know if it affect peak

taking the pipe off the actuator eliminates boost control, allowing the turbo to give all it can, so should direct you if its a boost control issue, or mechanical

Stu
__________________
CPP Motor Developments - CPP MLR page - CPP Facebook
RG Motorsport - www.rgmotorsport.co.uk

Evo 4-6 left over parts for sale
stu8 is offline   Reply With Quote
Old 21-06-2019, 20:04   #10
broraboy
Senior User
 
broraboy's Avatar
 
Join Date: Oct 2007
Location: Elgin, Scotland
Car: Evo 6 Gravel Rally Car
Posts: 742
Tested car on the road. 1.75 bar. Feels like it pulls OK but not really sharp. Rollers only has it pulling 1.3 bar or so. I understand the road puts a bit more load on the transmission but surely not that much.
__________________
Evo 6 Rally car and Evo 6.9 Rally car
broraboy is offline   Reply With Quote
Old 21-06-2019, 21:12   #11
kikiturbo
Senior User
 
Join Date: Feb 2008
Location: Croatia
Car: EVO 9 GSR
My Car
Posts: 2,584
sounds like a warped wastegate flapper... had a similar case.. .car was boosting about 1000 RPM late... slow spool and missing power
kikiturbo is offline   Reply With Quote
Old 21-06-2019, 21:14   #12
broraboy
Senior User
 
broraboy's Avatar
 
Join Date: Oct 2007
Location: Elgin, Scotland
Car: Evo 6 Gravel Rally Car
Posts: 742
Quote:
Originally Posted by kikiturbo View Post
sounds like a warped wastegate flapper... had a similar case.. .car was boosting about 1000 RPM late... slow spool and missing power
It's brand new. Last turbo did exactly the same. It's boosting to 1.75 bar which is fine. Wonder why we can't get power on the rollers
__________________
Evo 6 Rally car and Evo 6.9 Rally car
broraboy is offline   Reply With Quote
Old 22-06-2019, 09:20   #13
stu8
Senior User
 
stu8's Avatar
 
Join Date: Aug 2003
Location: Southport
Car: Evo V - geekmapped.com
My Car
Posts: 21,663
Quote:
Originally Posted by broraboy View Post
Stu, yes there is tension, I might increase it so as to eliminate it completely. Yes im running 34mm restrictor
did you try increasing the tension on the wastegate by the actuator?

https://www.lancerregister.com/showp...40&postcount=2

Stu
__________________
CPP Motor Developments - CPP MLR page - CPP Facebook
RG Motorsport - www.rgmotorsport.co.uk

Evo 4-6 left over parts for sale
stu8 is offline   Reply With Quote
Mitsubishi Lancer Register
Sponsored Links
Advertisement
 
Reply


Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT. The time now is 03:02.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.