Front drivers electric window problem - Mitsubishi Lancer Register Forum
 
 

Go Back   Mitsubishi Lancer Register Forum > Technical > Electrical / Security / ICE / Navigation

Reply
 
Thread Tools Rate Thread Display Modes
Old 13-09-2020, 10:35   #1
Skip Donohue
Registered User
 
Join Date: Nov 2018
Posts: 2
Front drivers electric window problem

Hi,
Having a problem with my front drivers side electric window. Window goes down nice and smooth but when you active the switch to raise the window it starts to make an awful grinding sound. It still moves upwards if you activate the switch a little at a time but if you activate it and hold it, it reaches a point where it stops and the window then goes back down.
I have removed the door card and can't see anything restricting the windows movement.
Can anyone help?

Here's the video:

https://www.streamable.com/m38jnl
Skip Donohue is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 13-09-2020, 11:52   #2
stu8
Senior User
 
stu8's Avatar
 
Join Date: Aug 2003
Location: Southport
Car: Evo V - geekmapped.com
My Car
Posts: 21,897
No sign of any fraying of the cable as the window goes up and down? Does it go up ok if you help the glass up by pulling it as you press the button?

Stu
__________________
CPP Motor Developments -
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
-
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

RG Motorsport -
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
stu8 is offline   Reply With Quote
Old 13-09-2020, 13:09   #3
Skip Donohue
Registered User
 
Join Date: Nov 2018
Posts: 2
Quote:
Originally Posted by stu8 View Post
No sign of any fraying of the cable as the window goes up and down? Does it go up ok if you help the glass up by pulling it as you press the button?

Stu
Can't see any frayed cables. Doesn't make any difference if I help it up or not. The grinding sound remains.
Thanks
Skip Donohue is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 13-09-2020, 13:21   #4
stu8
Senior User
 
stu8's Avatar
 
Join Date: Aug 2003
Location: Southport
Car: Evo V - geekmapped.com
My Car
Posts: 21,897
Maybe motor or gearbox failing, its a complete unit with cables and runners i think regardless

Stu
__________________
CPP Motor Developments -
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
-
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

RG Motorsport -
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
stu8 is offline   Reply With Quote
Mitsubishi Lancer Register
Sponsored Links
Advertisement
 
Reply


Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT. The time now is 15:14.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.