Load of blue smoke - Mitsubishi Lancer Register Forum
 
 

Go Back   Mitsubishi Lancer Register Forum > Technical > Engine / Turbo

Reply
 
Thread Tools Rate Thread Display Modes
Old 15-07-2019, 21:52   #1
jawadarif
Senior User
 
Join Date: Feb 2013
Posts: 516
Load of blue smoke

Ok last time I drove the car was on Thursday coming back from a mapper, car wasnt mapped at it had boost leaks, I change the dump valve which sorted out the issue of boost dropping , but decided to do a pressure test yesterday also did one today, started the car up and huge amonth of smoke came out, drove it for a bit and they still blue smoke coming out quite bad,
What can it be, check the intercooler pipe and they seem fine, no oil can't be the turbo, I don't thing it will be the piston as the engine been rebuild, is they something I could have damaged doing the pressure test.
jawadarif is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 16-07-2019, 09:20   #2
jawadarif
Senior User
 
Join Date: Feb 2013
Posts: 516
Just to update they no blue smoke when started up ,one the engine is warm, them it give out the smoke but only reaaly on boost ,nothing when in ideal
jawadarif is offline   Reply With Quote
Old 16-07-2019, 10:18   #3
swinks
Senior User
 
swinks's Avatar
 
Join Date: Dec 2009
Location: Lincolnshire
Car: ex-Mitsubishi Galant VR4, Mitsubishi Lancer Evolution 8 FQ300
Posts: 305
Send a message via Skype™ to swinks
Various reasons for blue smoke (oil burning), from easy and cheap fix like faulty PCV system, to more complex issues like worn out valve stem seals, turbo oil seals to engine problems.
You need to provide more details when actually smoke occurs, it give some clues.
__________________
ex-Galant VR4: 269 WHP and 325 LbFt torque at 0.9 bar (stock engine, turbo and ecu)
Evo 8 FQ300: 325 WHP and 375 LbFt torque at 1.6 bar
swinks is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 16-07-2019, 11:35   #4
jawadarif
Senior User
 
Join Date: Feb 2013
Posts: 516
Yesterday did it straight on startup, and also blue smoke when it was on idil, it been park up for a few day, , today did it when the engine was warm up and while driving , nothing on start up, and also nothing when the car was running idil
jawadarif is offline   Reply With Quote
Old 16-07-2019, 11:53   #5
swinks
Senior User
 
swinks's Avatar
 
Join Date: Dec 2009
Location: Lincolnshire
Car: ex-Mitsubishi Galant VR4, Mitsubishi Lancer Evolution 8 FQ300
Posts: 305
Send a message via Skype™ to swinks
Is there smoke when you are on boost?
Is there smoke when you release/close throttle and do "engine braking" (i.e coming down the hill slope)?
Is there smoke when after some driving you coming to a stanstill (like on traffic lights) and puff of smoke appears?

Each symptom points out to different issue.
__________________
ex-Galant VR4: 269 WHP and 325 LbFt torque at 0.9 bar (stock engine, turbo and ecu)
Evo 8 FQ300: 325 WHP and 375 LbFt torque at 1.6 bar
swinks is offline   Reply With Quote
Old 16-07-2019, 15:14   #6
jawadarif
Senior User
 
Join Date: Feb 2013
Posts: 516
Ok thank will check each and report back
jawadarif is offline   Reply With Quote
Old 16-07-2019, 19:47   #7
jawadarif
Senior User
 
Join Date: Feb 2013
Posts: 516
Smoke up when I'm hitting boost , see a blue smoke coming out ,but soon as I let go of the gas, the blue smoke clear up, and when running ideal , they blue smoke clear up, something to do with the turbo
jawadarif is offline   Reply With Quote
Old 17-07-2019, 07:59   #8
swinks
Senior User
 
swinks's Avatar
 
Join Date: Dec 2009
Location: Lincolnshire
Car: ex-Mitsubishi Galant VR4, Mitsubishi Lancer Evolution 8 FQ300
Posts: 305
Send a message via Skype™ to swinks
From your description very likely turbo seals gone.
__________________
ex-Galant VR4: 269 WHP and 325 LbFt torque at 0.9 bar (stock engine, turbo and ecu)
Evo 8 FQ300: 325 WHP and 375 LbFt torque at 1.6 bar
swinks is offline   Reply With Quote
Old 17-07-2019, 19:48   #9
jawadarif
Senior User
 
Join Date: Feb 2013
Posts: 516
Anyway to check the turbo seal and any recommendations for to get it refurb , it an 80 series turbo
jawadarif is offline   Reply With Quote
Mitsubishi Lancer Register
Sponsored Links
Advertisement
 
Reply


Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT. The time now is 12:07.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.