Turbo problem?! - Page 4 - Mitsubishi Lancer Register Forum
 
 

Go Back   Mitsubishi Lancer Register Forum > Technical > Engine / Turbo

Reply
 
Thread Tools Rate Thread Display Modes
Old 15-08-2018, 15:01   #46
Lee5
Moderator
 
Lee5's Avatar
 
Join Date: Apr 2003
Location: Kent
Car: Range Rover Sport~Porsche 911
My Car
Posts: 23,033
Quote:
Originally Posted by RaeTurbo View Post
Try it in fifth gear from 3000rpm see if it slips when the boost comes in uphill would be good, if it doesnít slip then by the time itís at full boost itís not the clutch.
We've done that and also held the car on full boost @50mph in a steady state and the clutch don't slip.
__________________


1st 500BHP E5 in the UK Running on Speed Density on Stock H8 Ecu

MLR Sprint Scrutineer

E5/6 Ecu SD Mapping Info Here & HERE
Lee5 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 15-08-2018, 15:42   #47
strange_days_uk
Simon - EVO V
 
strange_days_uk's Avatar
 
Join Date: Feb 2016
Car: EVO V
My Car
Posts: 1,780
Could it be something failing/slipping in the transfer box? Or somewhere else in the drivetrain other than the clutch? Maybe a gearbox problem, something slipping? I guess you tried it in different gears...
__________________
http://www.ap-tuning.co.uk/

Quote:
Originally Posted by Aidy View Post
Most TME owners have never driven an evo, including their own.
strange_days_uk is online now   Reply With Quote
Old 15-08-2018, 16:02   #48
Evo8.Rob
User
 
Join Date: Aug 2018
My Car
Posts: 41
Quote:
Originally Posted by strange_days_uk View Post
Could it be something failing/slipping in the transfer box? Or somewhere else in the drivetrain other than the clutch? Maybe a gearbox problem, something slipping? I guess you tried it in different gears...
I believe on the dyno 3rd,4th and 5th were tried.

I've tried all but 1st on the road. And exactly the same!

Last edited by Evo8.Rob; 15-08-2018 at 16:20..
Evo8.Rob is offline   Reply With Quote
Old 15-08-2018, 17:44   #49
strange_days_uk
Simon - EVO V
 
strange_days_uk's Avatar
 
Join Date: Feb 2016
Car: EVO V
My Car
Posts: 1,780
Quote:
Originally Posted by Evo8.Rob View Post
I believe on the dyno 3rd,4th and 5th were tried.

I've tried all but 1st on the road. And exactly the same!


Something with the ACD or AYC maybe?
__________________
http://www.ap-tuning.co.uk/

Quote:
Originally Posted by Aidy View Post
Most TME owners have never driven an evo, including their own.
strange_days_uk is online now   Reply With Quote
Old 16-08-2018, 07:09   #50
Evo8.Rob
User
 
Join Date: Aug 2018
My Car
Posts: 41
Quote:
Originally Posted by strange_days_uk View Post
Something with the ACD or AYC maybe?
Possibly- i'd of thought the Christmas tree would have appeared, but it's acting correctly and the lights are spot on!
Evo8.Rob is offline   Reply With Quote
Old 16-08-2018, 07:21   #51
swinks
Senior User
 
swinks's Avatar
 
Join Date: Dec 2009
Location: Lincolnshire
Car: ex-Mitsubishi Galant VR4, Mitsubishi Lancer Evolution 8 FQ300
Posts: 305
Send a message via Skype™ to swinks
My first thoughs were compressor surge, but seeing that Lee is trying to fix an issue I'm sure he ruled that out already.
__________________
ex-Galant VR4: 269 WHP and 325 LbFt torque at 0.9 bar (stock engine, turbo and ecu)
Evo 8 FQ300: 325 WHP and 375 LbFt torque at 1.6 bar
swinks is online now   Reply With Quote
Old 16-08-2018, 08:41   #52
Evo8.Rob
User
 
Join Date: Aug 2018
My Car
Posts: 41
Quote:
Originally Posted by swinks View Post
My first thoughs were compressor surge, but seeing that Lee is trying to fix an issue I'm sure he ruled that out already.
Yeah, One did think is was the inner vein on the turbo. But until i get it off i won't know!

Last edited by Evo8.Rob; 16-08-2018 at 08:47..
Evo8.Rob is offline   Reply With Quote
Old 16-08-2018, 23:30   #53
RaeTurbo
Senior User
 
RaeTurbo's Avatar
 
Join Date: Nov 2003
Location: S,Wales
Car: E4 Saddly demised. Now, 24V Senator (lpg) 24V carlton,Evo2 mapped antilagged and LC by Mr Fox.
My Car
Posts: 4,936
I very much doubt that it’s the separation piece in the turbine housing, most of the older cars 4 up of course, suffer this with little or no drama.
__________________
Evo2, 12.1 113 mph. First try.
RaeTurbo is offline   Reply With Quote
Old 17-08-2018, 08:11   #54
Evo8.Rob
User
 
Join Date: Aug 2018
My Car
Posts: 41
Should be splitting turbo middle of next week. I do have an 80 series to replace it with anyway!

Redirect 3 port boost solenoid vac lines as it looked like when I moved it and put the box back in I may have crushed them ever so slightly. They are now free and aren't restricted. Also removed the nipple from the 3rd unused port on solenoid.
Evo8.Rob is offline   Reply With Quote
Old 17-08-2018, 22:41   #55
RaeTurbo
Senior User
 
RaeTurbo's Avatar
 
Join Date: Nov 2003
Location: S,Wales
Car: E4 Saddly demised. Now, 24V Senator (lpg) 24V carlton,Evo2 mapped antilagged and LC by Mr Fox.
My Car
Posts: 4,936
Mmm��
__________________
Evo2, 12.1 113 mph. First try.
RaeTurbo is offline   Reply With Quote
Old 22-08-2018, 08:09   #56
Evo8.Rob
User
 
Join Date: Aug 2018
My Car
Posts: 41
Took my car to Fusion Motorsport last night, he ecu logged it.

Clutch is gone! Showed me all these graphs and numbers etc and he said 100% clutch!
Evo8.Rob is offline   Reply With Quote
Old 22-08-2018, 08:28   #57
Mita
Senior User
 
Join Date: Jul 2013
Posts: 8,935
We said that on page 1

Happy it’s sorted mate
Mita is offline   Reply With Quote
Old 22-08-2018, 08:32   #58
Evo8.Rob
User
 
Join Date: Aug 2018
My Car
Posts: 41
Quote:
Originally Posted by Mita View Post
We said that on page 1

Happy itís sorted mate
yeah i know There's no clutch smell or anything! that's why i couldn't believe it!
Evo8.Rob is offline   Reply With Quote
The Following User Says Thank You to Evo8.Rob For This Useful Post:
Mita (22-08-2018)
Mitsubishi Lancer Register
Sponsored Links
Advertisement
 
Reply


Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT. The time now is 12:23.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.