Low engine oil light - Mitsubishi Lancer Register Forum
 
 

Go Back   Mitsubishi Lancer Register Forum > Technical > Engine / Turbo

Reply
 
Thread Tools Rate Thread Display Modes
Old 11-10-2019, 09:57   #1
Naw
Registered User
 
Join Date: Nov 2014
Posts: 5
Low engine oil light

Hi guys , been trying to search this but had no luck , so hope you guys got any ideas to help me out . My car is an Evo X 2011 MR SST , been driving around for over 3000 km after engine build ( sleeved block , rods and pistons , cams and valves and a Garrett G2 GTX3576R , oil restrictor included . Car drives and shifts perfectly, no oil burnt , smoke and level after 3000 km like at start . After driving it at a sustained high speed of about 5 mins at 150 mph , my engine oil level light comes on , so I slowed down turned into a petrol station and checked oil level and it was perfect, tried a few other high speed pulled but not for very long time , did not happen again , car has a driven fab catch can too , any ideas on what could cause this , the sensor is perfectly connected, thx in advance.
Naw is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 11-10-2019, 10:14   #2
plip1953
Phil
 
plip1953's Avatar
 
Join Date: Feb 2008
Location: West Yorkshire
Car: Evo X RS
My Car
Posts: 10,679
Definitely oil level? I would try overfilling by half a litre. Are you seeing any/much oil in the catch tank?
__________________
Phil
plip1953 is offline   Reply With Quote
Old 11-10-2019, 13:20   #3
LEGNUMVR4
Senior User
 
Join Date: Aug 2010
Posts: 338
Is your oil grade suitable for sustained 150mph blasts?
5mins is a long time at that speed.

Last edited by LEGNUMVR4; 11-10-2019 at 13:22..
LEGNUMVR4 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 11-10-2019, 13:50   #4
Naw
Registered User
 
Join Date: Nov 2014
Posts: 5
Low oil level light

No , just those smelly vapors but hardly anything apart from the oil look inside catch can , the oil I am using will check exact name but itís 5W -50 Fuchs Titan , I had the oil level past the full mark at least 1/2 liter , could be slightly less or more , was filled to nearly that blurred mark above the hole for full level .
Naw is offline   Reply With Quote
Old 11-10-2019, 14:20   #5
grants
Senior User
 
grants's Avatar
 
Join Date: Sep 2003
My Car
Posts: 9,112
Just a thought. Does the X MR have a combined sensor for both level and temperature?

The EUDM Evo 8 had such a sensor, possibly also fitted to USDM cars?
grants is offline   Reply With Quote
Old 11-10-2019, 14:52   #6
kikiturbo
Senior User
 
Join Date: Feb 2008
Location: Croatia
Car: EVO 9 GSR
My Car
Posts: 2,672
yeah,

eudm cars have level sensor that liked to go bad..

I think evo X has the same
kikiturbo is offline   Reply With Quote
Old 11-10-2019, 15:13   #7
Phil2333
Tarmac Tyre Shredder
 
Phil2333's Avatar
 
Join Date: Dec 2004
Location: North west.
Car: Evo 6, Forged 2ltr 8MR engine...405/400
My Car
Posts: 14,373
5 mins at 150mph?...where were you?
__________________
My Evo 6 resto thread...

https://www.lancerregister.com/showth...ht=restoration
Phil2333 is offline   Reply With Quote
Old 11-10-2019, 15:39   #8
ypvs
Senior User
 
ypvs's Avatar
 
Join Date: Oct 2004
Location: surrey
Car: Silver 260 . On the up!!
My Car
Posts: 1,609
My evo 8 has such a sensor until i re wired it to always off. It had a mind of its own, right pain in the back side!!
__________________
ypvs is offline   Reply With Quote
Old 11-10-2019, 16:14   #9
Naw
Registered User
 
Join Date: Nov 2014
Posts: 5
Low oil level light

This is a 60 km motor way which has hardly any cars and perfect long stretchís which you can see for miles , totally safe to get to those speeds and unless itís a bird or small animal that might get in your path , could go flat out for most of the way except for the petrol station area approximately in the middle , I could say itís just outside Madrid , but as we know it would be illegal to do this there , it was in Germany
Naw is offline   Reply With Quote
Old 11-10-2019, 16:18   #10
Naw
Registered User
 
Join Date: Nov 2014
Posts: 5
Low oil level light

Yes I think my Evo X has that sensor which I checked and was connected solid , but donít think itís that as after I pulled over and checked oil level was correct , I did few more pulls even dropping down to 5 th gear at 7500 rpm and light did not show again , the only thing this were just like 1 min to 30 sec pulls .
Naw is offline   Reply With Quote
Old 11-10-2019, 16:21   #11
Naw
Registered User
 
Join Date: Nov 2014
Posts: 5
Low level oil light

I will have that sensor tested just to be sure .
Naw is offline   Reply With Quote
Mitsubishi Lancer Register
Sponsored Links
Advertisement
 
Reply


Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT. The time now is 03:08.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.