2015 Lancer 50k miles turbine sound when accelerating? - Mitsubishi Lancer Register Forum
 
 

Go Back   Mitsubishi Lancer Register Forum > General Stuff > Lancer EX 2000 Turbo

Reply
 
Thread Tools Rate Thread Display Modes
Old 25-10-2019, 00:17   #1
Jimbaker
Registered User
 
Join Date: Oct 2019
Posts: 1
2015 Lancer 50k miles turbine sound when accelerating?

Hey guys, So my Lancer just rolled over to 50k miles so most of it is still under warrenty.

I've recently started getting this loud fan/turbine sound when accelerating past 20/30mph, with the sound getting louder the faster you go. I took it to a dealership and they told me it was my tires and I attempted to tell them I didn't think so, but the mechanic countered with "I've done this work for 30 years now mimics sound that's a tire issue".

I proceeded to buy tires from them, but the problem was not solved. I'm hoping you guys can help.

So imagine a plane starting to take off... That's similar to the sound. It won't do it when in park and revving the engine, only does it when in motion. When going down the road I can shift it to neutral, and the sound dies down quite a bit which leads me to believe something transmission related? I could be wrong however. I checked my transmission fluid and it isn't low. Oil isn't low. Filters aren't dirty. Everything that I can see seems to be in working order, so I'm hoping you guys have an idea.

Thanks!
Jimbaker is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 25-10-2019, 10:51   #2
r3k1355
Senior User
 
Join Date: Jun 2006
Posts: 200
What model/engine?

I hope you got your money back from that lying dealership.
r3k1355 is offline   Reply With Quote
Old 25-10-2019, 18:55   #3
Dave F
Registered User
 
Join Date: Feb 2003
Location: Bristol
Car: Chevette with Lancer EX2000 Engine / Gearbox / Axle / LSD. MPI, Intercooled, Evo 3 Pistons & Turbo
Posts: 34
Guessing this is in the wrong section as this section is for the LT2000 (1980's RWD Pre Evo Turbo) but from your description it sounds like a turbo or intercooler hose leak as the engine will only really produce boost when under load.

If you have a boost gauge & the performance is less than normal I'd be looking there, if performance is still ok it's probably something else!

Good luck in your search.
__________________
1975 Vauxhall Chevette with Intercooled Lancer EX2000 Engine running MPI with T3 Turbo & Omex ECU

Complete Black 1981 Lancer EX2000 Road Car (No. 037); 1982 Lancer EX2000 Track Car (No. 334); White 1982 Lancer EX2000 Donor Car (No. 374)
Dave F is offline   Reply With Quote
Mitsubishi Lancer Register
Sponsored Links
Advertisement
 
Sponsored Links
Advertisement
 
Reply


Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT. The time now is 05:41.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.