Rear O2 CEL Warning - Ecuflash Fix Step by Step - Page 4 - Mitsubishi Lancer Register Forum
 
 

Go Back   Mitsubishi Lancer Register Forum > Technical > ECU / Mapping

Reply
 
Thread Tools Rating: Thread Rating: 51 votes, 5.00 average. Display Modes
Old 24-10-2008, 19:01   #46
grants
Senior User
 
grants's Avatar
 
Join Date: Sep 2003
My Car
Posts: 9,109
Gray

There are some, UK supplied ??, VII's with the rear lambda sensor

Pic from the "generic" VII WSM
Attached Images
 
grants is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 24-10-2008, 19:04   #47
adamarnold
Registered User
 
adamarnold's Avatar
 
Join Date: Apr 2006
Location: Bury St Edmunds
Car: Evo VII FQ300
My Car
Posts: 340
Thats what mine looks like thanks Grants
adamarnold is offline   Reply With Quote
Old 24-10-2008, 19:09   #48
grayw
Registered User
 
Join Date: Aug 2005
Location: Hampshire
Car: Evo
Posts: 19,543
Hi Grant, I have seen one fitted before, but it did not throw a CEL with a decat fitted.
grayw is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 24-10-2008, 19:12   #49
adamarnold
Registered User
 
adamarnold's Avatar
 
Join Date: Apr 2006
Location: Bury St Edmunds
Car: Evo VII FQ300
My Car
Posts: 340
Ok thanks Graham I just wanted to be sure it would not cause any issues if I decat
adamarnold is offline   Reply With Quote
Old 24-10-2008, 19:24   #50
grayw
Registered User
 
Join Date: Aug 2005
Location: Hampshire
Car: Evo
Posts: 19,543
It was fine with a decat on the last one I played with.
grayw is offline   Reply With Quote
Old 13-11-2008, 17:15   #51
Guille_evo
Registered User
 
Join Date: Nov 2008
Location: Argentina - Santa Fe - Rosario
Car: Mitsubishi Lancer Evo VI RS-2
Posts: 7
Send a message via MSN to Guille_evo
Hi, I┤m a new member but I read much in this forum. My English is not fluent. I want to see the possibility of mapping an ECU Evo VI. I have also EcuFlash, Evoscan and reprogramming cable. When I read the Rom with EcuFlash does not show anything in the left column. I apologize if this is cleared somewhere in the forum and I appreciate any information.
__________________
:m itsi::mit si::mitsi :
Guille_evo is offline   Reply With Quote
Old 13-11-2008, 17:19   #52
grayw
Registered User
 
Join Date: Aug 2005
Location: Hampshire
Car: Evo
Posts: 19,543
You can read the VI ECU at present with Ecuflash, but flashing back is not possible at present with that software.
grayw is offline   Reply With Quote
Old 13-11-2008, 17:35   #53
Guille_evo
Registered User
 
Join Date: Nov 2008
Location: Argentina - Santa Fe - Rosario
Car: Mitsubishi Lancer Evo VI RS-2
Posts: 7
Send a message via MSN to Guille_evo
You know the existence of any software capable of doing that?
__________________
:m itsi::mit si::mitsi :
Guille_evo is offline   Reply With Quote
Old 13-11-2008, 17:43   #54
grayw
Registered User
 
Join Date: Aug 2005
Location: Hampshire
Car: Evo
Posts: 19,543
Ecutek can flash the V and VI ECU's.

Quote:
Originally Posted by Guille_evo View Post
You know the existence of any software capable of doing that?
grayw is offline   Reply With Quote
Old 13-11-2008, 17:54   #55
hazzer
 
Join Date: Nov 2007
Posts: 22
if the cel comes on will the car go in limp mode...
hazzer is offline   Reply With Quote
Old 13-11-2008, 21:20   #56
grayw
Registered User
 
Join Date: Aug 2005
Location: Hampshire
Car: Evo
Posts: 19,543
No, but as I said in your other thread, If the CEL is on and another problem happens you will not know about it.

Quote:
Originally Posted by hazzer View Post
if the cel comes on will the car go in limp mode...
grayw is offline   Reply With Quote
Old 01-04-2009, 10:34   #57
DanielN
Registered User
 
Join Date: Apr 2009
Car: EVO9 GSR
My Car
Posts: 161
Quote:
Originally Posted by _Biggles_ View Post
How to fix your ECU to remove rear O2 sensor checks and CEL warnings after de-cat.

Hi Ladies and Gentlespoons. Many of us have had a decat. Some choose to fix the CEL indication by use of a special spacer or O2 simulator. Well i found O2 simulation too complex and fiddly to wire, the cel fix spacer from the states fouls the underbody on long journeys as the exhaust expands.

There has to be a better way.....

And yes there is! Been working with grayw today to eliminate the checks for the rear O2 sensor on a standard ECU. Today i can report thats now been fixed!!

So if _Biggles_ the ECU noob can do this, so can anybody.

OK you do have a list of bits to acquire so heres the list:
  • Laptop : DUH yep no laptop no ECU chatting, beg borrow, try not to steal
  • Limitless or Tactrix Cable : So those can be gotten from Grant @ Gizzmo Electronics (support your MLR trader!) or Limitless themselves
  • Ecuflash : Superb FREE software you are going to love forever after today acquired from www.openecu.org
  • Aktivematrix ECU Unlocker : Some ECU's are locked after tuning. BOO! This unlocks them. Go to www.aktivematrix.com, sign for free account, download it!
  • ROM Definition File : Different for every evo, but go to openecu.org and hit the forums they are all there! Look for your vehicle, if you are struggling to find it, make a post, someone will help you pick the right one!
  • You might also wish to consider Mitsulogger or Evoscan as well, you can check for knock etc with those! Evoscan is not free but its excellent. Useful for checking your engine & map health
So thats your parts and software list! Got it all? OK lets get on with fixing the CEL warning once and for all!
Hi mate,

Is this will work also for 88840017 Rom id?

Thanks
DanielN is offline   Reply With Quote
Old 01-04-2009, 12:12   #58
grayw
Registered User
 
Join Date: Aug 2005
Location: Hampshire
Car: Evo
Posts: 19,543
What car is 88840017 from? You would need to look at the periphery codes.
grayw is offline   Reply With Quote
Old 09-04-2009, 13:54   #59
DanielN
Registered User
 
Join Date: Apr 2009
Car: EVO9 GSR
My Car
Posts: 161
Quote:
Originally Posted by grayw View Post
What car is 88840017 from? You would need to look at the periphery codes.
Hi grayw,

88840017 is a EDM version rom id for Evo 9 2006.

This is my actual map now. 3 months ago I had 88840013 USDM version but I switch to 88840017 EDM.

I look into my periphery codes and I have in ECU periphery2 FCA bit4 enable P0300 value is 1.

This is the only thing that I did but after 100 km the cell is on again.

I do something wrong?

Thanks
DanielN is offline   Reply With Quote
Old 09-04-2009, 15:59   #60
grayw
Registered User
 
Join Date: Aug 2005
Location: Hampshire
Car: Evo
Posts: 19,543
This guide was written for the EDM VIII, so there may be differences. You could run a modified Tephra rom with the rear O2 simulator.
grayw is offline   Reply With Quote
Mitsubishi Lancer Register
Sponsored Links
Advertisement
 
Reply


Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT. The time now is 07:49.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.