Shorted out at radio: Fuse??? Evo7 - Mitsubishi Lancer Register Forum
 
 

Go Back   Mitsubishi Lancer Register Forum > Technical > Electrical / Security / ICE / Navigation

Reply
 
Thread Tools Rate Thread Display Modes
Old 24-05-2020, 00:16   #1
Stofff
Registered User
 
Join Date: May 2020
Posts: 6
Exclamation Shorted out at radio: Fuse??? Evo7

Hoping someone can help me here...
Evo 7 GSR
I Was swapping my radio and a wire shorted. I presumed blowing a fuse but I am unable to find anything blown.

The interior light, stereo, clock, central locking, elec mirrors, rear wiper and washer have stopped working properly.
It appears a Permanent Live connection/fuse has gone as when the ignition is off i am unable to use central locking, trip counter zero’s and the clock goes back to 1:00.

Really appreciate any info someone can give me!!!

Thanks
Stofff is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 24-05-2020, 08:38   #2
jhfozzy
S.Wales R.O./Electrician
 
jhfozzy's Avatar
 
Join Date: Apr 2007
Location: Swansea
Car: Evo VI
My Car
Posts: 4,094
It'll be the fuse, there are two for the radio, one perm and one ignition.

Remove and check continuity.
__________________
John
jhfozzy is offline   Reply With Quote
Old 24-05-2020, 14:20   #3
Stofff
Registered User
 
Join Date: May 2020
Posts: 6
Quote:
Originally Posted by jhfozzy View Post
It'll be the fuse, there are two for the radio, one perm and one ignition.

Remove and check continuity.
Which fuse and where is it located?
Stofff is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 24-05-2020, 16:02   #4
TrickyDick
Very Senior User
 
TrickyDick's Avatar
 
Join Date: Jul 2006
Location: Surrey
Car: VII FQ-300x2
Posts: 938
Check dedicated fuses 15,17 & 18 in the main fuse box under bonnet.
TrickyDick is offline   Reply With Quote
Old 24-05-2020, 16:12   #5
TrickyDick
Very Senior User
 
TrickyDick's Avatar
 
Join Date: Jul 2006
Location: Surrey
Car: VII FQ-300x2
Posts: 938
There are also a couple of related fuses in the J/B that is inside down below the steering wheel.
TrickyDick is offline   Reply With Quote
Old 24-05-2020, 19:16   #6
jhfozzy
S.Wales R.O./Electrician
 
jhfozzy's Avatar
 
Join Date: Apr 2007
Location: Swansea
Car: Evo VI
My Car
Posts: 4,094
Quote:
Originally Posted by Stofff View Post
Which fuse and where is it located?
In the fusebox under the bonnet.

Fuse 15 (7.5A), red circle, is for the side lights including the stereo.
Fuse 17 (10A), blue circle, is the ignition feed to the stereo.
Fuse 18 (10A), green circle, is the permanent live to the stereo.
Attached Images
   
__________________
John
jhfozzy is offline   Reply With Quote
Old 25-05-2020, 20:57   #7
Stofff
Registered User
 
Join Date: May 2020
Posts: 6
Thanks for the reply guys. This appears to be the wiring diagram that I keep reading about but it does not match My fuse box. See attached pic:

Note NO FUSE 17 - 18

Last edited by Stofff; 25-05-2020 at 20:59.. Reason: Adding info
Stofff is offline   Reply With Quote
Old 25-05-2020, 20:59   #8
jhfozzy
S.Wales R.O./Electrician
 
jhfozzy's Avatar
 
Join Date: Apr 2007
Location: Swansea
Car: Evo VI
My Car
Posts: 4,094
Quote:
Originally Posted by Stofff View Post
Thanks for the reply guys. This appears to be the wiring diagram that I keep reading about but it does not match My fuse box. See attached pic:
Your fusebox matches that diagram?

Are there terminals in position 17 & 18?
__________________
John

Last edited by jhfozzy; 25-05-2020 at 21:00..
jhfozzy is offline   Reply With Quote
Old 25-05-2020, 21:04   #9
jhfozzy
S.Wales R.O./Electrician
 
jhfozzy's Avatar
 
Join Date: Apr 2007
Location: Swansea
Car: Evo VI
My Car
Posts: 4,094
I was looking for a picture of the fusebox and this thread came up.

https://www.evolutionm.net/forums/la...working-2.html
__________________
John
jhfozzy is offline   Reply With Quote
Old 25-05-2020, 23:10   #10
Stofff
Registered User
 
Join Date: May 2020
Posts: 6
All the threads and posts I have found speak of this yellow box with 2 10a fuses in it and peoples struggle at removing them. This fuse holder and fuses are not in my fuse box I.e fuses 17 - 18 they have never been there. Compare this fuse box with the previous one. This is a strange one. Thanks for your time and help looking at this.
Stofff is offline   Reply With Quote
Old 25-05-2020, 23:44   #11
jhfozzy
S.Wales R.O./Electrician
 
jhfozzy's Avatar
 
Join Date: Apr 2007
Location: Swansea
Car: Evo VI
My Car
Posts: 4,094
Have you got a close-up of the slot on your fusebox where the yellow bit should be?

Maybe someone lost the yellow part and bypassed it?
__________________
John
jhfozzy is offline   Reply With Quote
Old 26-05-2020, 15:41   #12
grants
Senior User
 
grants's Avatar
 
Join Date: Sep 2003
My Car
Posts: 9,377
I have an E8 FQ300 loom and there are no fuses in locations 17/18

What happens in ETACS; i don't want to know !!
grants is offline   Reply With Quote
The Following User Says Thank You to grants For This Useful Post:
jhfozzy (26-05-2020)
Mitsubishi Lancer Register
Sponsored Links
Advertisement
 
Reply


Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT. The time now is 08:43.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.