Mitsubishi Lancer Register Forum - Search Results
 
 

Go Back   Mitsubishi Lancer Register Forum > Search Forums

Showing results 1 to 8 of 8
Search took 0.00 seconds.
Search: Posts Made By: DannyTk
Forum: Trader Discussion 05-03-2019, 06:29
Replies: 4
Views: 579
Posted By DannyTk
I just bit the bullet an drove from Solihull to...

I just bit the bullet an drove from Solihull to indigo-gt.
Thought it was worth it, made a day walking round the little village there.
Forum: Lancer Chat 18-01-2019, 21:59
Replies: 3
Views: 626
Posted By DannyTk
My friend brought a forester sti last year from...

My friend brought a forester sti last year from torque GT, he's well impressed by them. He has been In touch with them recently getting advice, so helpful to him.
Forum: Gearbox / Clutch / Transmission 03-12-2018, 13:30
Replies: 7
Views: 1,299
Posted By DannyTk
What makes you think it's the unit? What's the...

What makes you think it's the unit? What's the symptoms?
Can the valves not be switched out?
I have nightmares over my sst �� just curious for future issues that may occur with mine.
Forum: Lancer Chat 02-10-2018, 00:53
Replies: 10
Views: 1,333
Posted By DannyTk
Hi, as mentioned it's not rare as a 330. Mines a...

Hi, as mentioned it's not rare as a 330. Mines a 330 but i got the sst.

I really wanted a fq330 manual an couldn't afford the jump in price for a fq360.
Wish I had gone for a 300 manual, the sst...
Forum: Technical Questions 10-09-2018, 21:11
Replies: 5
Views: 453
Posted By DannyTk
You tested the voltage on the battery? I fitted a...

You tested the voltage on the battery? I fitted a new battery and it solved alot of issues for me. Like the rough idling.
I also tried re teaching the key whilst in the barrel.
But whilst trying...
Forum: Technical Questions 29-08-2018, 15:54
Replies: 5
Views: 453
Posted By DannyTk
Sst �� Jumped it after a few hours waiting for...

Sst ��
Jumped it after a few hours waiting for the better half to save me.
It was a dead battery, an when the car first starts now it idles rough an won't rev well for 10 seconds of running.
New...
Forum: Technical Questions 28-08-2018, 20:19
Replies: 5
Views: 453
Posted By DannyTk
Evo X won't start

Hi,
I've just parked on a car park ramp, after 5 mins with engine off but ignition on. I got ASC service light, awc service light and AFS service light. When I try to start the car. All lights flash...
Forum: Technical Questions 20-08-2018, 21:17
Replies: 6
Views: 1,078
Posted By DannyTk
Hi, I've got mine come up once or twice since...

Hi,
I've got mine come up once or twice since buying the car a few months ago.
There seems to be kits on eBay, but if you rebuild it you then have to bleed the system. Which is the part I'm...
Showing results 1 to 8 of 8

 
Forum Jump


All times are GMT. The time now is 17:30.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.