Evo VI Front Wipers [Archive] - Mitsubishi Lancer Register Forum

Evo VI Front Wipers

Jasonc488
01-04-2012, 18:11
Hi all,

Just got this problem following a wash and then a motorway cruise.

I was driving along on the motorway following a hand wash when water was spraying up on my windscreen from the spolier blade of the wipers.

I turned on the wipers and they worked for about 2-3 rounds then stopped dead in the centre of windscreen. I squirted more water from washer to maybe help give it something wet to travel on, but still nothing. I tried this at speed 1 wipe and speed 2 wipe and nothing.

But, the wipers work at the highest setting (3). When I got home, tried all this again and the same. Wipers only wipe at speed setting 3? Would this be a stalk problem would anyone know?

Thanks in advance.

Jason

straightliner
01-04-2012, 18:21
Sounds like a stalk problem mate

Jasonc488
01-04-2012, 18:28
Do you know if its an easy swap? For a second hand one.

Sent from my HTC Desire HD using Tapatalk

straightliner
01-04-2012, 18:38
I'd try a spray with some contact cleaner first but no idea how to replace them I don't expect it's hard

Jasonc488
01-04-2012, 19:13
Will try and see what I can do, thanks for directing me.

Sent from my HTC Desire HD using Tapatalk

TerryA
01-04-2012, 19:19
not hard but is fiddly

https://www.lancerregister.com/showthread.php?t=385962

I have a spare if you need it but try other things first - working away all next week though so will be out of touch till Sat

SORRY - was thinking indicator (which I have) but think it will be similar as is on other side of column ?

Jasonc488
01-04-2012, 19:59
not hard but is fiddly

https://www.lancerregister.com/showthread.php?t=385962

I have a spare if you need it but try other things first - working away all next week though so will be out of touch till Sat

SORRY - was thinking indicator (which I have) but think it will be similar as is on other side of column ?

Thanks for the link Terry, will give me an idea of what to expect when attempting this.

Lucky bank holiday is coming along...

Sent from my HTC Desire HD using Tapatalk