Evo 8 FQ-300 blown dipped beam (HID) [Archive] - Mitsubishi Lancer Register Forum

Evo 8 FQ-300 blown dipped beam (HID)

Kartingdaz
03-02-2004, 10:33
The original post;

8 FQ-300 Dip Beam blown
With only 2000 miles on the clock the passenger side dip beam on my 8 FQ-300 has stopped working.

Anyone else experienced this problem - was it the bulb - can you tell if the bulb is blown with the discharge bulbs ?

Just been in contact with my local dealer to get a price for fitting a new bulb - was told it was rather complicated as there were many options - is this true? Surely if you have the VIN and have been told its an 8 FQ-300 you can work out a price!

Anyone know how much?


Last edited by Kartingdaz on 02-02-2004 at 12:04

Well the car has been to the dealer (just as another 8 was leaving after having its inter cooler pipes tightened), front bumper off apparently to get to the HID unit/ignitor/bulb.

Well its not the bulb! Its the ignitor unit, part on order from Japan - anyone know if there is somewhere else in the UK to get one of these parts from? The dealer suggested Portbury - waiting for him to get back to me.

Mrk
03-02-2004, 11:48
What happened to your warranty??

Kartingdaz
03-02-2004, 11:58
Warranty - waiiting to hear but indications are that the part and labour will be covered - [email protected]@@@@ hope so as the bulb alone was approx. £140 hate to think what the ignitor will be.

Jedi
03-02-2004, 22:14
I just had the whole headlamp replaced, as it steamed up. I was told itís over a grand to replace.

Your warranty must cover this unless you have damage?

Jedi

Kartingdaz
04-02-2004, 10:44
ditto Jedi

Garage just called to let me know that the whole headlight is going to be replace (under warranty) as its quicker than waiting for the ignitor to come from Japan.

So far very happy with the service.

Garage also confirmed that they double checked my intercooler hoses and the gear linkage recall - I didnt prompt them.

Hope to have the car back tomorrow evening - hooray

Trebor
19-05-2004, 12:12
Originally posted by Kartingdaz
The original post;

8 FQ-300 Dip Beam blown
With only 2000 miles on the clock the passenger side dip beam on my 8 FQ-300 has stopped working.

Anyone else experienced this problem - was it the bulb - can you tell if the bulb is blown with the discharge bulbs ?



Exactly the same has happened to my E8 FQ-300, two months old now with 1600 miles. Passenger side also. Just waiting for dealer to confirm when they'll have a new headlight in (to cover whether bulb or ignitor) then to arrange getting it booked in.

I guess, as with most electronic devices, these things generally fail quite early in their life .... or last the expected distance.

In the meantime I guess i'll be using the front fogs if necessary.

Trebor
27-05-2004, 16:33
Had the headlight unit replaced yesterday by the boys down in Brighton.

Hopefully the replacement will last the distance.