Mitsiart....a big thanks [Archive] - Mitsubishi Lancer Register Forum

Mitsiart....a big thanks

heaveho
30-09-2010, 16:40
Hi, didn't really see anywhere appropriate to post this, as these people aren't known on here, but I wanted to recommend this company to anyone living close enough to Portsmouth to be able to make use of them. They're an independant Mitsi specialist. If it needs to be moved Mods, feel free.

In July, I tasked them with removing the head, inlet manifold, turbo etc from my 8 and replacing it with the stuff I had from a 9 ( thanks Daz ), so that I could have the Mivec. Even though this was a first for them, they not only did the job in the time they said for the price they quoted ( less than a cambelt service at the local dealers! ), but overcame many of the niggles that doing the mechanical part of the swap entails, and in the process stripped and inspected the 9 parts to be fitted, replacing stem oil seals and cam seals etc on my instruction.

Due to a suspected Mivec problem, unrelated to their work, I've barely used the car, and as a consequence, they haven't seen the car again until yesterday, even though it was due back in with them soon after the initial head swap. During this time, it became apparent to me that they had undercharged me, by forgetting they had had to change the plugs ( expensive on a 9 ), but when reminded, insisted that I could wait 'til it was back in before paying.

It went back yesterday to have the fluids in the diff, gear and transfer boxes changed, and for them to look at the Mivec on the MUT, ( they have all the equipment necessary to look after Evos ) for which they charged me a frankly absurd 98 plus what I already owed them, putting the cherry on the day by giving the Mivec the green light. After the frankly shocking service I've had from the local dealers, to have found somewhere that makes as much effort as I do with my car is a revelation. There's no question that this'll be where my car goes from now on.

Credit where it's due, I'd like to help get them some business as a thank you, and I think other Evo owners who can use them will find Ian and Paul, the owners, a breath of fresh air. Their details are below:

Mitsiart.
Unit 3A,
Venture Court,
Ackworth Road,
Hilsea,
Portsmouth,Hants.
PO3 5RY.
Tel. 02392 691535
Mob. 07941 002988 or 07912 212473

Cheers, Andy.

R-Spec Performance
30-09-2010, 17:02
.....................................As Andy falls to his knees and starts performing oral sex :lol:

Only joking mate, heard good things about them :smthumbup

heaveho
30-09-2010, 18:04
.....................................As Andy falls to his knees and starts performing oral sex :lol:

Only joking mate, heard good things about them :smthumbup

Lol, got to get them to stand on a stepladder for the oral mate, got a bad back at the mo! If you haven't had it from a Geordie, you've never lived.:smthumbup

You'll be applying for a job there now you know about the "extras"?:D

smiles
04-10-2010, 11:21
Been wondering where to get my 6 serviced, thanks for helping me decide.... booked in for next tuesday :smthumbup

heaveho
16-10-2010, 16:51
Been wondering where to get my 6 serviced, thanks for helping me decide.... booked in for next tuesday :smthumbup

Hi, doubt you'll regret it, I'll be there with mine from now on, Elmer Fudpucker ( Jon, ultra fussy with his 9, doubt he'll disagree! ) uses them also.:smthumbup

smiles
16-10-2010, 17:00
Hi, doubt you'll regret it, I'll be there with mine from now on, Elmer Fudpucker ( Jon, ultra fussy with his 9, doubt he'll disagree! ) uses them also.:smthumbup

Good to hear :smthumbup I remember Elmer when was on Scoobynet and his cars were always mint; loved his white Spec C I think he had (might have been a RA version). So thats good enough endorsement for me :smthumbup

heaveho
16-10-2010, 18:29
Good to hear :smthumbup I remember Elmer when was on Scoobynet and his cars were always mint; loved his white Spec C I think he had (might have been a RA version). So thats good enough endorsement for me :smthumbup

Lol, yeah, that's where I knew him from, I reckon he must have had 5 Scoobies in a row before he came to his senses!

smiles
16-10-2010, 18:37
Lol, yeah, that's where I knew him from, I reckon he must have had 5 Scoobies in a row before he came to his senses!

Same here, but I didnt follow the sheep, I had wagons :D Prodrive WRX Blobeye Wagon, STI 5 Wagon, STI 7 Wagon, Fozzy S-Turbo, Fozzy STI MY06 Litchfield, Leggy Wagon WR Limited Litchfield then saw the light :D

dazxxx
16-10-2010, 20:46
:smthumbup:smthumbup:smthumbup glad to help mate and glad you got it all sorted in the end.....so what was the problem on the mivec ???? was it the oil feed/pressure as suspected from the bolts and speaking of bolts did you get them or what :wallbang::wallbang::wallbang:.... my seats from my white one would look lovely in your car:mhihi::mhihi::crackup::crackup:....

heaveho
16-10-2010, 22:41
:smthumbup:smthumbup:smthumbup glad to help mate and glad you got it all sorted in the end.....so what was the problem on the mivec ???? was it the oil feed/pressure as suspected from the bolts and speaking of bolts did you get them or what :wallbang::wallbang::wallbang:.... my seats from my white one would look lovely in your car:mhihi::mhihi::crackup::crackup:....

Alright geezer, erm, bit of a red herring with the Mivec, nothing wrong with it, faulty 3 port causing the problems. Got it mapped today, there's almost too much for the chassis!

Never got the bolts Daz, the P.O. were a waste of time when I tried to find out anything, and the way things are it turns out they wouldn't have made any difference anyway, but thanks for the help.

Don't start trying to sell me more stuff, I'm in enough trouble as it is!:D

dazxxx
16-10-2010, 22:44
you can never have too much....going to put the white one to bed permanently and concentrate on the hot rods for a bit i think, also need to get a big garage built at new house for my tool box's :mhihi::mhihi::lol::lol:...so what power did it produce.....had a bloke drive my forged 9 the other day and he couldnt belive the difference with the mivec, so much so he bought it :crackup::crackup::smthumbup

bloody post office :wallbang::wallbang::wallbang: i'm down 2 sets mivec feed bolts now:cry::cry::cry: na its ok just one of them things:D:D

heaveho
17-10-2010, 08:58
you can never have too much....going to put the white one to bed permanently and concentrate on the hot rods for a bit i think, also need to get a big garage built at new house for my tool box's :mhihi::mhihi::lol::lol:...so what power did it produce.....had a bloke drive my forged 9 the other day and he couldnt belive the difference with the mivec, so much so he bought it :crackup::crackup::smthumbup

bloody post office :wallbang::wallbang::wallbang: i'm down 2 sets mivec feed bolts now:cry::cry::cry: na its ok just one of them things:D:D

Daz, did you end up sending out the 2nd set as well? Jesus, I thought it was bad enough the 1st set disappeared, didn't realise another set's out there somewhere....I'll have another go at the P.O. next week.

dazxxx
17-10-2010, 09:15
Daz, did you end up sending out the 2nd set as well? Jesus, I thought it was bad enough the 1st set disappeared, didn't realise another set's out there somewhere....I'll have another go at the P.O. next week.


it be ok mate only a few bolts,no doubt some more will pop up when i take the white one apart:naughty::naughty::crackup:....so just goes to show that a simple thing like the boost port would cause problems on mivec side:wallbang::wallbang: glad its all done now and your enjoying it:smthumbup:smthumbup

heaveho
17-10-2010, 10:11
it be ok mate only a few bolts,no doubt some more will pop up when i take the white one apart:naughty::naughty::crackup:....so just goes to show that a simple thing like the boost port would cause problems on mivec side:wallbang::wallbang: glad its all done now and your enjoying it:smthumbup:smthumbup

Cheers fella, it wasn't anything related to the Mivec in the end, that was just a red herring - Dave at R-Spec sent me another 3-port to try on the off chance, and I only fitted it out of desperation really....I was running out of other things to try by then! I fitted it and went out to take some paperwork to the office, first time I gave it full throttle it nearly threw me out the rear windscreen....it went off the boost gauge, and I nearly shat myself 'cos I wasn't expecting it!

Got it mapped yesterday, had a right moment afterwards, it blew a boost pipe off while I was overtaking a line of cars on a B road, coasted into a layby and ended up doing a right bodge to get it home....sorted now hopefully, gonna go out and cane it now to make sure it's alright!:D