ecu numbers. [Archive] - Mitsubishi Lancer Register Forum

ecu numbers.

evoiv1stone
20-04-2008, 21:53
got a prob with my evo 4.its got an evo7 engine,evo 6 turbo,evo 5 injectors,evo 4 inlet manifold.but the ecu is not from a 4.part num ber on it is MR514364. did a search on the net,and i found it belongs to a TM GSR,whatever that means? here,s the link,interesting.

http://translate.google.com/translate?hl=en&sl=ja&u=http://www.ricv.zaq.ne.jp/ksrom/sakiokurizaiko.htm&sa=X&oi=translate&resnum=2&ct=result&prev=/search%3Fq%3Dmr514364%26hl%3Den

nippy hippy
20-04-2008, 21:57
hey, get a re-map if it is, that forge will provide you with good high held boost

evoiv1stone
20-04-2008, 22:06
will be needing it mapped,still got idling issues and still got low boost,0.75bar,poo bud.funny thing though it will go to 0.9bar at 5000 5500rpm and above.not like my last one,it would boost peak at 3500 all the way.i have checked everything except the ecu....may give indigo a call soon..hate being first owner of an import always bits to sort out,,,i want to keep this one though.

Ryan!!
21-04-2008, 14:29
TM= Tommi Makkinen ie a evo 6.5

Spanpody
21-04-2008, 18:05
the ecu is not from a 4You dont want an Evo 4 ECU if you are running Evo 5 injectors (560cc/min). The Evo 4 ECU runs 510cc/min injectors.

You need the ECU from the Evo 5/6, as such the TME ECU you have is fine.

evoiv1stone
21-04-2008, 20:47
will be using this ecu,no choice at the mo.just looked at the ecu board and nothing looks fried,phew,and i dont know if its right but,all the wires going to ecu connector blocks are evo 4.none of them have been cut modded or spliced into,just plugged straight in? isnt there some modding to do here?

todd-w
21-04-2008, 21:30
will be using this ecu,no choice at the mo.just looked at the ecu board and nothing looks fried,phew,and i dont know if its right but,all the wires going to ecu connector blocks are evo 4.none of them have been cut modded or spliced into,just plugged straight in? isnt there some modding to do here?

no plugs straight in,
MR514364 afaik is 6 rs ecu

evoiv1stone
21-04-2008, 21:37
thats good to hear budd.whats bugging me is the low boost,took it out for a run earlier and 0.79bar boost peak? and irregular idling.what if i used a boost controller,what would be the safest peak level to go to,without causing problems?i seem to think may be the inlet manifold gasket is leaking how could i possibly test it?

evoiv1stone
22-04-2008, 20:16
found reason for low/normal intermittent boost levels.theres a clamp midway on the turbo,holding turbo and exhaust housing together,the turbo seems to be miss alighned causing the actuator rod to rest against the exhaust side of turbo,how can i adjust it without major stripdowns? the rods already shifting off centre and i put spacers between actuator bracket,didnt help much though.

evonut270
22-04-2008, 20:20
what actuator is it?

evoiv1stone
22-04-2008, 20:25
its a forge mate,my old standard one was in same state too.thought thats the way it is,till i looked and realised the real cause.the turbo needs turning a few degrees to move the actuator forward a bit.how is that done?

evonut270
22-04-2008, 20:29
there are bolts/clamp on the turbo that can be loosened to turn the housings.