Go Back   Mitsubishi Lancer Register Forum > General Stuff > Lancer Chat

Reply
 
Thread Tools Rating: Thread Rating: 164 votes, 5.00 average. Display Modes
Old 12-01-2017, 17:43   #2596
Silent_Scone
Senior User
 
Silent_Scone's Avatar
 
Join Date: Feb 2016
Location: West Sussex
Car: Viii FQ340 MR (Stock - EBC Blue pads)
Posts: 405
Quote:
Originally Posted by VI_Shooter View Post
Yep they are really useful to be honest and light up white when you wire them up correctly and link to the main lamp switch, etc.

Come along to a meet mate I can show you. IF you get stuck ask MitsiArt as they fitted mine and even had to make part of the wiring loom as I only had half of it.

Cheers mate, yeah will be doing some meets this year. in the south east. I was thinking of getting Dyntech to fit them whilst it's in for brakes. This is how it came...(no temp sensor)
Silent_Scone is offline   Reply With Quote
Old 12-01-2017, 17:55   #2597
Yozza
Senior User
 
Yozza's Avatar
 
Join Date: Dec 2015
Location: Cheshire
Car: Evo IX FQ-340
My Car
Posts: 153
What did you do to your evo today?

Look at this nasty set and their asking for £275!!!
https://www.ebay.co.uk/itm/291807294473
Yozza is offline   Reply With Quote
Old 12-01-2017, 18:03   #2598
Silent_Scone
Senior User
 
Silent_Scone's Avatar
 
Join Date: Feb 2016
Location: West Sussex
Car: Viii FQ340 MR (Stock - EBC Blue pads)
Posts: 405
Quote:
Originally Posted by Yozza View Post
Look at this nasty set and their asking for £275!!!
https://www.ebay.co.uk/itm/291807294473
Yeah, saw them. Look like they were found underwater!
Silent_Scone is offline   Reply With Quote
Old 13-01-2017, 10:31   #2599
matevo
User
 
matevo's Avatar
 
Join Date: Jun 2015
Location: West Sussex
Car: Evo VIII 260, A3 Cabriolet 1.8tfsi
My Car
Posts: 96
Took the kids to school and used snow mode for the first time
Attached Images
 
__________________
matevo is offline   Reply With Quote
The Following 4 Users Say Thank You to matevo For This Useful Post:
Leo6072 (13-01-2017), nickyd150 (16-01-2017), OGA11Y (13-01-2017), river evo 6 (13-01-2017)
Old 13-01-2017, 13:47   #2600
Gavalar
Senior User
 
Join Date: Apr 2015
Location: Uxbridge
Car: Evo 9 fq360 Mr
Posts: 2,199
Great mate bet u spun it up
Gavalar is offline   Reply With Quote
The Following User Says Thank You to Gavalar For This Useful Post:
matevo (13-01-2017)
Old 13-01-2017, 17:20   #2601
VI_Shooter
Regional Organiser
 
VI_Shooter's Avatar
 
Join Date: May 2014
Location: Portsmouth
Car: Stock Silver VI GSR from Nippon!
My Car
Posts: 4,498
Quote:
Originally Posted by Silent_Scone View Post
Yeah, saw them. Look like they were found underwater!
Yes those ones looked jank!

The set you have look good. You only have half the wiring loom BUT its the important bit with the connectors to the gauges. Bullet connectors and the rest can be made up a lot easier. That is what MitsiArt did for me. The Vac pipe for the boost is easy enough, as is the battery charger. Trickier is the temp sensor, but mine ended up in the sump IIRC. It can go other places like the oil filter housing I believe. Get someone to do it for you unless you really know what you are doing I reckon.
__________________
"Do not meddle in the affairs of Lancers, for they are rally and quick to 60"
VI_Shooter is online now   Reply With Quote
The Following User Says Thank You to VI_Shooter For This Useful Post:
Silent_Scone (13-01-2017)
Mitsubishi Lancer Register
Reply


Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump




All times are GMT. The time now is 12:40.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.