Go Back   Mitsubishi Lancer Register Forum > Technical > Technical Questions

Reply
 
Thread Tools Rate Thread Display Modes
Old 09-04-2012, 18:40   #1
dip
Senior User
 
Join Date: Dec 2010
My Car
Posts: 225
evo 5 help needed

hi new engine installed starts up ok and idles fine but when warmed up it starts to over fuel spluters and cuts out also notticed rev counter jumping up eraticaly. car will not start again untill it cools down again then the same fault happens again

Last edited by dip; 09-04-2012 at 19:08..
dip is offline   Reply With Quote
Old 09-04-2012, 18:42   #2
stu8
Senior User
 
stu8's Avatar
 
Join Date: Aug 2003
Location: Southport
Car: Evo V - geekmapped.com
Posts: 15,590
was the engine a standard engine out of a 5? Why did you change the engine? What makes you think it is overfueling? any mods?

Stu
__________________
CPP Motor Developments - www.cpp-motor-developments.co.uk
RG Motorsport - www.rgmotorsport.co.uk

MY PARTS FOR SALE - BRAKE PADS
stu8 is offline   Reply With Quote
Old 09-04-2012, 19:11   #3
dip
Senior User
 
Join Date: Dec 2010
My Car
Posts: 225
its newly built forged engine. Reason i think its over fueling is because once the plugs are removed excess fuel can be seen in the bores.

Mods are - S90 throttle body, gsc s1 cams, 750 injectors, autobann intercooler with pipes.

Dip
dip is offline   Reply With Quote
Old 09-04-2012, 19:14   #4
stu8
Senior User
 
stu8's Avatar
 
Join Date: Aug 2003
Location: Southport
Car: Evo V - geekmapped.com
Posts: 15,590
Quote:
Originally Posted by dip View Post
its newly built forged engine. Reason i think its over fueling is because once the plugs are removed excess fuel can be seen in the bores.

Mods are - S90 throttle body, gsc s1 cams, 750 injectors, autobann intercooler with pipes.

Dip
has it been mapped, what ecu is on it? is that ecu mapped for those injectors?

Stu
__________________
CPP Motor Developments - www.cpp-motor-developments.co.uk
RG Motorsport - www.rgmotorsport.co.uk

MY PARTS FOR SALE - BRAKE PADS
stu8 is offline   Reply With Quote
Old 09-04-2012, 19:17   #5
dip
Senior User
 
Join Date: Dec 2010
My Car
Posts: 225
My ecu was a stage 1 modded with ecutek, but for my previous engine. No mapping has been done yet as i am trying to run the engine in.
dip is offline   Reply With Quote
Old 09-04-2012, 19:19   #6
stu8
Senior User
 
stu8's Avatar
 
Join Date: Aug 2003
Location: Southport
Car: Evo V - geekmapped.com
Posts: 15,590
Quote:
Originally Posted by dip View Post
My ecu was a stage 1 modded with ecutek, but for my previous engine. No mapping has been done yet as i am trying to run the engine in.
well, for starters, you should be using the injectors the ecu was mapped for, in my limited knowledge, 750's instead of standard 560's will be overfueling massively

Stu
__________________
CPP Motor Developments - www.cpp-motor-developments.co.uk
RG Motorsport - www.rgmotorsport.co.uk

MY PARTS FOR SALE - BRAKE PADS
stu8 is offline   Reply With Quote
Old 09-04-2012, 19:20   #7
stu8
Senior User
 
stu8's Avatar
 
Join Date: Aug 2003
Location: Southport
Car: Evo V - geekmapped.com
Posts: 15,590
what else has been fitted after the ecutek?

Stu
__________________
CPP Motor Developments - www.cpp-motor-developments.co.uk
RG Motorsport - www.rgmotorsport.co.uk

MY PARTS FOR SALE - BRAKE PADS
stu8 is offline   Reply With Quote
Old 09-04-2012, 19:24   #8
dip
Senior User
 
Join Date: Dec 2010
My Car
Posts: 225
Thanks for the info Stu will try to source some 560's as my old engine was sold with them.

Dip
dip is offline   Reply With Quote
Old 09-04-2012, 19:26   #9
dip
Senior User
 
Join Date: Dec 2010
My Car
Posts: 225
After the ecutek was mapped with stage 1 mods, my new setup now has new internals e.g. piston/rods/lash adjusters, has s90 throttle, 750 injectors, bigger intercooler with pipes, and the gcs s1 cams.
dip is offline   Reply With Quote
Old 09-04-2012, 19:27   #10
stu8
Senior User
 
stu8's Avatar
 
Join Date: Aug 2003
Location: Southport
Car: Evo V - geekmapped.com
Posts: 15,590
Quote:
Originally Posted by dip View Post
After the ecutek was mapped with stage 1 mods, my new setup now has new internals e.g. piston/rods/lash adjusters, has s90 throttle, 750 injectors, bigger intercooler with pipes, and the gcs s1 cams.
Dip
might be easier to get a basic map put on it to run it in

I'd be more tempted to do this, then remap properly once run in, as it is a completely different engine, with different spec to what the ecu was set up for

Stu
__________________
CPP Motor Developments - www.cpp-motor-developments.co.uk
RG Motorsport - www.rgmotorsport.co.uk

MY PARTS FOR SALE - BRAKE PADS
stu8 is offline   Reply With Quote
Old 09-04-2012, 19:30   #11
dip
Senior User
 
Join Date: Dec 2010
My Car
Posts: 225
Have been talking with lee5 as i am getting it mapped by him, will talk to him and ask if he can put a basic map to run it in.

Dip
dip is offline   Reply With Quote
Old 09-04-2012, 19:30   #12
stu8
Senior User
 
stu8's Avatar
 
Join Date: Aug 2003
Location: Southport
Car: Evo V - geekmapped.com
Posts: 15,590
o yer, dont continue trying to run it until you have sorted the injectors, or the remap

Stu
__________________
CPP Motor Developments - www.cpp-motor-developments.co.uk
RG Motorsport - www.rgmotorsport.co.uk

MY PARTS FOR SALE - BRAKE PADS
stu8 is offline   Reply With Quote
Old 09-04-2012, 19:30   #13
stu8
Senior User
 
stu8's Avatar
 
Join Date: Aug 2003
Location: Southport
Car: Evo V - geekmapped.com
Posts: 15,590
Quote:
Originally Posted by dip View Post
Have been talking with lee5 as i am getting it mapped by him, will talk to him and ask if he can put a basic map to run it in.

Dip
__________________
CPP Motor Developments - www.cpp-motor-developments.co.uk
RG Motorsport - www.rgmotorsport.co.uk

MY PARTS FOR SALE - BRAKE PADS
stu8 is offline   Reply With Quote
Old 14-04-2012, 17:21   #14
dip
Senior User
 
Join Date: Dec 2010
My Car
Posts: 225
hi stu purchased 560 injecters and installed still having same problem of engine over fuelling after 20 min. also tried cam sensor as my rev gauge becomes more eratic just before fault occurs and still same problem. any help appreciated . thanks
dip is offline   Reply With Quote
Old 14-04-2012, 17:24   #15
sbn1979
Hi
 
Join Date: Oct 2009
Location: Wednesbury and East Yorkshire
Car: Evo 6 Tommi Mak
My Car
Posts: 7,150
whats your wideband saying?
sbn1979 is offline   Reply With Quote
Mitsubishi Lancer Register
Reply


Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump




All times are GMT. The time now is 07:42.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.